'

LEGO Star Wars: The Force Awakens PC System Requirements

LEGO Star Wars: The Force Awakens PC System Requirements

LEGO Star Wars: The Force Awakens PC System Requirements 

LEGO Star Wars: The Force Awakens PC System Requirements

 

The PC system requirements have been announced for Lego Star Wars: The Force Awakens,  a game that looks into the story of the latest Star Wars movie and adds the fun and humor that you can expect from a Lego game.

 

      In LEGO Star Wars: The Force Awakens, relive the epic action from the blockbuster film in way that only LEGO can offer, featuring brand new story content from the Star Wars Universe that explores the time between Star Wars: Return of the Jedi and Star Wars: The Force Awakens.

 

 

The game will require a quad core CPU and a minimum of 4GB of system memory.  The game runs on directX 9c and will require a Nvidia GT 430 or an ATI HD 6850 or above to run, meaning that pretty much any modern gaming system should be able to run this game. 

 

MINIMUM: 

    • OS: Windows XVista/7/8/10 
    • Processor: Intel Core 2 Quad Q6600 (2.4 GHz) / AMD Phenom x4 9850 (2.5 GHz) 
    • Memory: 4 GB RAM 
    • Graphics: GeForce GT 430 (1024 MB)/ Radeon HD 6850 (1024 MB) 
    • DirectX: Version 9.0c 
    • Network: Broadband Internet connection 
    • Storage: 14 GB available space 
    • Sound Card: DirectX compatible 
    • Additional Notes: Windows XP and DirectX® 9.0b and below not supported

 

RECOMMENDED: 

    • OS: Windows Vista/7/8/10 
    • Processor: Intel i5, 4 x 2.6 GHz or AMD equivalent 
    • Memory: 4 GB RAM 
    • Graphics: NVIDIA GeForce GTX 480 or ATI Radeon HD 5850 or better, 1Gb RAM 
    • DirectX: Version 11 
    • Network: Broadband Internet connection 
    • Storage: 14 GB available space 
    • Sound Card: DirectX compatible 
    • Additional Notes: Windows XP and DirectX® 9.0b and below not supported

 

 
 
«Prev 1 Next»

Most Recent Comments

17-04-2016, 17:55:32

xnax2802
How good of them to suggest relevant hardware... wait...Quote

17-04-2016, 18:00:56

Tolemac
I just want BB-8 Quote

17-04-2016, 19:42:13

Wraith
Soooo the requirements have not changed since, Avengers, Super Heroes or Jurassic World. Fancy that, they're not exactly the most demanding titles.Quote

18-04-2016, 01:52:15

NeverBackDown
Quote:
Originally Posted by Tolemac View Post
I just want BB-8
I just want SoloQuote

18-04-2016, 12:48:53

SuB
Quote:
Originally Posted by NeverBackDown View Post
I just want Solo
Too soonQuote
Reply
x

Register for the OC3D Newsletter

Subscribing to the OC3D newsletter will keep you up-to-date on the latest technology reviews, competitions and goings-on at Overclock3D. We won't share your email address with ANYONE, and we will only email you with updates on site news, reviews, and competitions and you can unsubscribe easily at any time.

Simply enter your name and email address into the box below and be sure to click on the links in the confirmation emails that will arrive in your e-mail shortly after to complete the registration.

If you run into any problems, just drop us a message on the forums.